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Objectives
Excel Formulas & Functions

Large Excel Projects

Excel protection and security

Exploring Excel's Database Features

Data analysis

Advanced Analysis with PivotTables

Customizing excel
New Perspectives on Microsoft Excel © Godson Hance Mkaro | 2018
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Hint: The motto of this training is:
“Say No to manual Work”
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Excel Formulas & Functions
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Sum, Average, Min, Max and Count

General Syntax:

 Average Function =AVERAGE(cell_range)

Minimum value function =MIN (cell_range)

Maximum value function =MAX (cell_range)

Counting (Qty) function =COUNT (cell_range)

 NB: Auto Average, Auto Min, Auto Max, Auto count
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Exercise Files: average.xlsx



Working with Dates and Time 

 Today’s date (static): (CTRL + ;)

 Today’s date (Dynamic): =TODAY()

 Today’s Date and Time(Dynamic): =NOW()

 NB: To refresh the changes type in anything or 
make any changes in the values in the 
worksheet. However for shortcut key press F9
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Exercise Files: dates.xlsx



Absolute vs. Relative Referencing

 Relative Referencing: e.g. =SUM(A1:A10)

 Absolute Referencing:  (Hint: Use F4 Key to lock)

 Locking Rows e.g. =SUM(A$1:A$10)

 Locking Columns e.g. =SUM($A1:$A10)

 Locking a Cell e.g. =A1/$A$10
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Exercise Files: absolute refs.xlsx



3.5. Text functions

 Length of a Text =LEN(text)

 Left characters =LEFT (text, no. of characters from left)

 Right characters =RIGHT (text, no. of characters from right)

 Middle characters =MID(text,starting_char, no. of chars)

 Finding the position/starting point of a word or character in a text 

= FIND(text_to_find, within_a_text, starting_point)

 Removing all spaces between words = TRIM(text)

 Upper case = UPPER(text)

 Lower case = LOWER(text)

 Counting cells containing text values = COUNTA(value1,value2…)
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If statements

 If statement have three arguments
 The conditional statement to test
 The value if statement is true
 The value if statement is false

General syntax: 
= IF(logical_test, value_if_true, value_if_false)    
e.g. =if(A6>10,”High”,”Low”)
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Exercise Files: if.xlsx



Nested If statements

General Syntax
=IF(logical_test1, value_if_true, 
IF(logical_test2, value_if_true, 
IF(logical_test2 ,value_if_true, 
value_if_false)

 Example:
=IF(A6>80,”A”, IF(A6>60,”B”,IF(A6>40,”C”, 
IF(A6>20,”D”, “F”)))
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Exercise Files: Nested if.xlsx



SUMIF statements
General Syntax: 
=SUMIF(Lookup_Range,Criteria,SumRange)

Example:
=SUMIF(A1:A10,”ASSET”,”B1:B10)
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Exercise Files: sum if.xlsx



AVERAGEIF statements
General Syntax: 
=AVERAGEIF(Lookup_Range,criteria,Average_Range)

Example:
=AVERAGEIF(A1:A10,”ASSET”,”B1:B10)
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Exercise Files: sum if.xlsx



COUNTIF statements
General Syntax: 

=COUNTIF (Lookup_Range, criteria)

Example: =COUNTIF(A1:A10,”ASSET”)
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Exercise Files: sum if.xlsx



Naming and using cells
 To give a name to a cell range simply select the

cells you want to name and then while still
selected type in the name in the name box

 Alternatively: Select the cells including the
headers then go to formulas tab -> create from
selection

 Applying the names in the formulas:
E.g. =SUM(January) instead of =SUM(B6:B9)
NB: Formulas tab -> Use in formula or Press the F3
key to enter the cells name while in the formula
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Exercise Files: creating range names.xlsx



Lookup Functions
VLOOKUP: Used to lookup data that are

arranged down the columns (Vertically to
each other)

HLOOKUP: Used to lookup data that are
arranged across rows (Horizontally to each
other)

NB: VLOOKUP is much more common
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Exercise Files: lookups.xlsx



Lookup Functions

VLOOKUP General Syntax: 
=VLOOKUP(lookup value, data range, column
no. to match, True/False)

HLOOKUP General Syntax:
=HLOOKUP(lookup value, data range, row no. to
match, True/False)
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Exercise Files: lookups.xlsx



LOOKUP statements
=VLOOKUP(value_to_lookup, look_up_range, 
column_index,TRUE (1) or FALSE (0)

Keys things to consider:
 Lookup_value should be put in “” or referred to a

particular cell
 data_range should start from the column

containing values that you want to lookup
 Column # to match. should be counted from the

column containing lookup value
 TRUE=Approximate match & FALSE(0)=Exact Match
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Exercise Files: lookups.xlsx



2. Large Excel Projects
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 Freezing the Top Row: View Tab > Freeze pans > Freeze Top Row
 Freezing the First Column: View Tab > Freeze pans > Freeze First column

Freezing Multiple Rows and columns:
 Freezing Rows: First split the work sheet into two views by dragging

the top handler of vertical the scroll bar down below the rows that
you want to freeze then go to View Tab > Freeze pans

 Freezing Columns: First split the work sheet into two views by dragging
the right handler of the horizontal scroll bar to the left just before the
columns that you want to freeze then go to View Tab > Freeze pans

 Freezing both Rows and Columns: First split the rows then split the
columns as explained in the two steps above before freezing the
panes then after setting the desired split area then go to View Tab >
Freeze pans

 NB: To undo the split click the split button and to unfreeze click unfreeze

Freezing panes
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Exercise Files: freezing panes.xlsx



 First insert page break after each instance of data that you want to
appear in separate pages. Before inserting the page break make
sure u have selected the row that you want it to appear first in the
next page (page layout > Breaks > Insert page break)

 Hint: In excel incase you want to repeat the same action multiple times
simply perform the action once then to use F4 key to repeat the action

 To select the rows to repeat as titles when printing the document go to
page layout > Print Titles > Rows to repeat

 To select the columns to repeat as titles when printing the document go
to page layout > Print Titles > columns to repeat

 NB: To view the changes go to File > Print > print preview and scroll to see how the
page breaks have affected the file and how the rows/columns are repeating

Repeating row and column titles
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Exercise Files: repeating rows.xlsx



 To hide columns or rows simply select the columns or rows
then while selected right click and select Hide from the pop
up menu

 To Unhide rows or columns select rows or columns that are
adjacent to the hidden rows/columns then right click and
select unhide from the pop up menu

 To Group multiple rows/columns simply select the rows or
columns then go to the Data Tab > Group or use keyboard
shortcut (ALT + SHIFT + →)

 To Ungroup rows/columns simply select the rows or columns
then go to the Data Tab > Ungroup or use keyboard shortcut
(ALT + SHIFT + ←)

 HINT: To ungroup all the sheet got to Data Tab > Clear outline

Hiding or grouping rows and columns
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Exercise Files: grouping.xlsx



3. Excel protection and security
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 Locking Cells: Home > select the cells that you want to be editable
(unlocked) > go to Format > Lock cells > while still selecting the
cells that are not to be locked > go again to Format > Protect
worksheet > Remove the tick from select locked cells check box >
Enter password > Re-enter password

 Unlocking cells: Home > Format > Unprotect sheet > Enter password
 Protecting the entire work book/ Excel File with password: File > Info

> permissions > Protect workbook > Encrypt with password > Enter
Password > OK

 Mark document as Final so as to indicate that editing is complete
and this is the final version of the document: File > Info > permissions
> Protect workbook > Mark as final

 Add a digital signature to ensure security of the file when sharing
across the internet: This can be done by purchasing Security
certificates from trusted sources e.g. from www.globalsign.com

Workbook permissions and protection
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Exercise Files: permissions.xlsx



4. Exploring Excel's Database Features

25



 To split the data into multiple cells first insert a new
column in the right side of the column containing the
data to be split then select the data in the column
containing data to be split (CTRL + SHIFT + ↓) then go to
Data Tab > Text to columns > Delimited > choose
delimiter that has separated the data e.g. Space
delimited > Next > Format the data if necessary > Finish

 Alternatively: Go to the next empty Column or insert a
new column in front of the column containing values
you want to split then write the First word from the
sentence you want to split and ENTER then go to Home
> Flash Fill (Shortcut CTRL + E) then do the same for the
Remaining words in the sentence

Splitting cell data into multiple cells
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Exercise Files: splitting.xlsx



To join data into multiple cells first insert a new
column in the right side of the column containing the
data to be split then:
Joining by using Formula: (&)
 E.g. = A5 & B5
Joining by using Function: CONCATENATE ( )
 E.g. = concatenation(A5 ,B5)

Alternatively: Go to the next empty Column or insert a new
column in front of the column containing values you want to
join then write the full sentence you want to obtain from the
first cell in the columns and ENTER then go to Home > Flash
Fill (Shortcut CTRL + E) then do the same for the Remaining
words in the sentence

Joining data from multiple cells
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Exercise Files: merging.xlsx



 To convert a data range into a table simply click
anywhere in the data range and go to Insert >
Table

 Removing Duplicates: Click anywhere in the data
in the table then go to Design Tab > Remove
Duplicates > Select the fields that should be
compared when removing duplicates > OK

 To convert a table into data range: Design Tab >
Convert to range

Using tables to sort and filter data
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Exercise Files: tables.xlsx



 Hint: Before inserting subtotals make sure your data is
properly sorted in the columns that requires the subtotals

 Data Tab > Sub Totals > Choose at each change in > Choose
the function e.g. sum, average, count, etc. > Choose which
column or data field to add subtotal to

 NB: To add more subtotals without replacing make sure to uncheck
the Replace current subtotals check box and to insert page break
after each subtotal make sure to check the page break between
groups check box

 To Remove subtotals: Data Tab > Sub Totals > Remove All

Inserting automatic subtotals

29

Exercise Files: subtotals.xlsx



5. Analyzing Data
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 Auditing Tools are available under the Formula Tab
 Important Terminologies:
 A dependency is a formula that a cell feeds into
 A Precedent is the data that feeds into a formula

 Direct Dependency: a formula that a cell directly feeds into. Key
board shortcut: CTRL + ]

 Indirect Dependency: formula that a cell indirectly feeds into. Key
board shortcut: CTRL + SHIFT + ]

 Direct Precedency: data that directly feeds into a formula. Key
board shortcut: CTRL + [

 Indirect Precedency: data that indirectly feeds into a formula. Key
board shortcut: CTRL + SHIFT + [

 Checking the cause of errors in the formula: Click the formula with
errors > go to formula tab > Error checking (Down arrow) > Trace error

Using auditing to diagram
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Exercise Files: auditing.xlsx



 Formula evaluating Tool is available under the
Formula Tab > Evaluate Formula

 The Evaluate formula tool evaluates the validity of
the formula by checking the actual data
produced by the formula computations and
comparing the data with the actual results.

 To evaluate a formula click the cell that contains
the formula > go to formula tab > click evaluate
formula > click evaluate

Using evaluation in Excel
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Exercise Files: evaluate.xlsx



 The Goal seek tool helps a user to evaluate various
outcomes incase the original goal or plan is
changed.

 To perform a goal seek analysis: go to Data > What
if Analysis > Goal Seek > Set cell that you want to
analyze > To value: that you want it to be the
outcome > By changing cell: value that you want
to change if the goal sought is changed

Working with Goal Seek
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Exercise Files: goal seek.xlsx



 Data tables can be used to evaluate various
outcomes incase a certain goal or plan changes
e.g. how will the monthly loan payments change if
the loan repayment period changes

 Select all the values in the table then go to Data
Tab > What if Analysis > Data Table > Enter the
cell(s) that will affect the columns/rows’ outcome
incase it changes > OK

Using data tables in formulas
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Exercise Files: data tables.xlsx



 Scenario manager can be used to evaluate
various outcomes of a formula in multiple scenario
changes.

 Select the values used as inputs in the formula then
go to Data Tab > What if Analysis > Scenario
manager > Add > OK > Put in a scenario name >
Put in a comment (optional) > Enter values for the
scenario > Add (to add another scenario) >
Repeat Entering values for other scenarios > OK >
Show > click on scenarios to navigate through
outcomes > Click Summary to get a full report

Using scenarios in formulas
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Exercise Files: scenarios.xlsx



6. Advanced Analysis with PivotTables

36



 Pivot tables are useful when
 You have a lot of data to analyze
 Can’t see how they relate to each other

 Pivot tables summarizes data and Turn data into knowledge
 Anatomy/Structure of the Pivot table

 Row Labels
 Column Labels
 Summary area
 Report filter

 NB: Pivot Tables are flexible such that in just one or two clicks
you can swap columns, rows and filters

Discovering PivotTables
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Exercise Files: sparklines.xlsx



Creating pivot table: Click any where in the data
range > go to Insert Tab > Pivot table >

 Hint: It is more practical to create it in a separate
sheet

 Drag and drop the items in the pivot table field list
into the columns labels, rows labels , values and
report filter boxes according to the structure that
you desire for the pivot table

Creating a basic PivotTable
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Exercise Files: create pivot table.xlsx



Modifying the pivot table simply move around the
the items in the pivot table field list into the
columns labels, rows labels , values and report filter
boxes according to the structure that you desire
for the pivot table when modifying the pivot table
structure

 Slicers: are interactive panels that can be used in
filtering data Inserting Slicers: Options > Insert Slicer

Modifying a PivotTable 

39

Exercise Files: modifying a pivottable.xlsx



7. Customizing Excel
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Go to the QAT click the down arrow and
choose the command you want to add to
the QAT however for more commands click
more commands then choose the
command you want and click Add

Alternatively go to the command you
want, right click it and choose Add to
Quick Access Tool Bar

Customizing the Quick Access Toolbar (QAT)
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Exercise Files: recording macro.xlsx



Right click any where on the ribbon bar
and choose Customize the Ribbon

NB: You can not add a command directly
to the Tab, you should add it to a group.
However you can add a group to an
existing Tab a you can create your own
Group or even your own custom Tab by
clicking New Group or New Tab

To share the customization to other
computers choose Import/Export

Customizing the Ribbon bar
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Exercise Files: recording macro.xlsx



Thank You for your time

Any question?
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You are officially an 
Advanced user of 

MS EXCEL
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THE END
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